Project X Forums



It is currently Mon Nov 19, 2018 2:22 pm

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: This mod needed to be compatible with the latest version.
PostPosted: Wed Sep 27, 2017 2:34 am 
Offline

Joined: Tue Sep 26, 2017 8:43 am
Posts: 4
When will this mod get the next update that is compatible with v3.7.2.1? I had forced to use 3.6.31.0 (which is uncomfortable for using previous version for me) in order to use Project X to extend my Worms Armageddon gameplay... It's getting few buggy, but it's almost playable for me.

Entuser needed to get back to work for Project X. Without him, How would we get this mod updated?


Top
 Profile  
Reply with quote  
 Post subject: Re: This mod needed to be compatible with the latest version
PostPosted: Wed Sep 27, 2017 2:07 pm 
Offline

Joined: Wed Sep 09, 2015 2:15 pm
Posts: 43
I think you speak for pretty much everyone when you say it would be great to have it working with the latest worms version. Unfortunately, I think if Entuser was going to update it, he would have by now.

From what I've heard, after the 3.8 update for this game which is hopefully due by the end of this year, the plan is to then add in similar functionality that PX gives, into the game itself, which would then allow us to create stuff for the game without using PX. I guess that would be for the fabled 4.0 update that nobody has provided any timeframe for that I can find.

Personally, I'd rather that 3.8 was delayed and support added where PX could be used with it, thus solving many operating system and rendering issues people experience when having to downgrade to run this. Then again, I don't know much about programming so maybe it isn't possible.


Top
 Profile  
Reply with quote  
 Post subject: Re: This mod needed to be compatible with the latest version
PostPosted: Wed Sep 27, 2017 2:34 pm 
Offline

Joined: Tue Sep 26, 2017 8:43 am
Posts: 4
[

Mmmm... So do you mean.... The 3.8 update of Worms Armageddon will optionally have Project X mod-like feature that contains things such as Highlanders and custom weapons? If that happened, This gonna extend Worms Armageddon gameplay with that mod-like. I love interacting with new stuffs for my favorite games. :D

But I don't know what's the next update will be? Either 3.8 or 4.0...

Besides, Four years since 3.7.2.1 while six years since PX 0.8.0, That sure take sooooo~ long.... :(


Top
 Profile  
Reply with quote  
 Post subject: Re: This mod needed to be compatible with the latest version
PostPosted: Wed Sep 27, 2017 3:15 pm 
Offline

Joined: Wed Sep 09, 2015 2:15 pm
Posts: 43
No, I mean't that it would be nice if 3.8 would allow px to work with it, but I don't think that will happen, especially if 4.0 update is going to add similar functions to what px does now.

3.8 update is due this winter hopefully, and then 4.0 will come after, but I don't know when.

I agree also, that PX increases the lifespan of this game a lot.


Top
 Profile  
Reply with quote  
 Post subject: Re: This mod needed to be compatible with the latest version
PostPosted: Wed Sep 27, 2017 11:14 pm 
Offline

Joined: Tue Sep 26, 2017 8:43 am
Posts: 4
Will there be 3.9 between 3.8 and 4.0? I also have played Worms Armageddon for very long time.

I also wishes that Worms Armageddon will have W.M.D. vehicles.


Top
 Profile  
Reply with quote  
 Post subject: Re: This mod needed to be compatible with the latest version
PostPosted: Fri Sep 29, 2017 8:07 am 
Offline

Joined: Mon Jul 30, 2012 9:45 am
Posts: 194
A 3.8 update is supposed to come out by the end of the year. This update is years overdue because the maintainers have lost interest in WA and projects have been left unfinished for years. They now plan to remove all unfinished stuff entirely and put out all the stuff that is finished (probably mostly bugfixes). My feeling is that this will be the last update for WA. Planning for the fabled 4.0 version begun pretty much a decade ago, and development has also stalled long ago.

So WA v3.8 update could come soon, or it could come never. Keep in mind that the PX mod needs to be rewritten for every new WA version and from what I understand, this is a huge undertaking every time.

In may this year I was told by StepS that Entuser is back and would be working on updating PX, but whether that is actually happening or not is another question, especially keeping in mind the above.

WA has enjoyed an incredible lifespan, and maybe some fresh blood will be injected in the future, but for now I would suggest enjoy what we have, and don't hold your breath for any new developments.

_________________
http://twitch.tv/wormsdotam | http://worms.am/hl | http://worms.am/zombieshopper | http://worms.am/golf | http://worms.am/holywar


Top
 Profile  
Reply with quote  
 Post subject: Re: This mod needed to be compatible with the latest version
PostPosted: Fri Sep 29, 2017 11:25 am 
Offline

Joined: Wed Sep 09, 2015 2:15 pm
Posts: 43
Hey Raffie,

Good to see you are around still.

I have StepS on steam but I try not to bug him if can be avoided. I wanted to pitch in on the Entuser return part though. If it is indeed true that he is back and working on PX, then I suspect he will likely wait for the 3.8 update and then get PX working with that. There is little point in updating to work with this version if Worms is going to be updated again in the coming months. That being said, it would be nice to get official confirmation from Entuser that this is the case and I wonder why this hasn't been done at this stage.

I think it will be safe to say that after 3.8, there likely isn't going to be any further updates for quite so time. One can only hope that this project is updated alongside 3.8 that is due.


Top
 Profile  
Reply with quote  
 Post subject: Re: This mod needed to be compatible with the latest version
PostPosted: Fri Sep 29, 2017 11:56 am 
Offline

Joined: Tue Sep 26, 2017 8:43 am
Posts: 4
So, i wonder what's new for WA v3.8?

Besides, I predict the next version number of Project X will might be v0.9 or v1.0.

Also, Speaking of Project X, I want to try out Highlander in Worms Armageddon. I urgently wants to record the gameplay of Worms Armageddon with Project X mod.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Skin by Lucas Kane